Install Openstack in CentOS 8

 Openstack is an set of software component provide cloud infrastructure.

Infrastructure as a service

//disable firewall

[root@centos boobalan]# systemctl disable firewalld.service

Removed /etc/systemd/system/multi-user.target.wants/firewalld.service.

Removed /etc/systemd/system/dbus-org.fedoraproject.FirewallD1.service.

[root@centos boobalan]# systemctl stop firewalld.service

[root@centos boobalan]#

//disable NetworkManger instead we can use network
//OpenStack networking currently does not work on systems that have the Network Manager service enabled.


[root@centos boobalan]# systemctl disable NetworkManager
Removed /etc/systemd/system/multi-user.target.wants/NetworkManager.service.
Removed /etc/systemd/system/dbus-org.freedesktop.nm-dispatcher.service.
Removed /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service.
[root@centos boobalan]# systemctl stop NetworkManager

[root@centos boobalan]# systemctl enable network
Failed to enable unit: Unit file network.service does not exist.
[root@centos boobalan]# systemctl start network
Failed to start network.service: Unit network.service not found.

[root@centos boobalan]# systemctl is-active network
inactive

[root@centos boobalan]# dnf install network-scripts

[root@centos boobalan]# systemctl is-active network
inactive
[root@centos boobalan]# systemctl enable network
network.service is not a native service, redirecting to systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable network
[root@centos boobalan]# systemctl is-active network
inactive
[root@centos boobalan]# systemctl start network
[root@centos boobalan]# systemctl is-active network
active


//install latest version of openstack (wallaby)

//but check latest package availability from openstack website

https://docs.openstack.org/install-guide/environment-packages-rdo.html

[root@centos boobalan]# yum install centos-release-openstack-victoria

[root@centos boobalan]# yum update -y

[root@centos boobalan]# yum install -y openstack-packstack

//here we going to install packstack , Packstack is a time saving method to install openstack it used only for general purpose infrastructure.

//if you want any specify network focus, or storage focus or control focus then need to install all the key element /services from one by one with different different VM's 

[root@centos boobalan]# packstack --allinone

//this will install all key componenet nova,glance,..etc.. all in one. 

//if you get any error occure during this installation the packstack create answer file , there you get the failed details and reinstall them.

//error spotted

192.168.0.2_controller.pp:                        [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.2_controller.pp
Error: Function lookup() did not find a value for the name 'DEFAULT_EXEC_TIMEOUT'
You will find full trace in log /var/tmp/packstack/20210804-023440-d8e77vvl/manifests/192.168.0.2_controller.pp.log
Please check log file /var/tmp/packstack/20210804-023440-d8e77vvl/openstack-setup.log for more information
Additional information:
 * Parameter CONFIG_NEUTRON_L2_AGENT: You have chosen OVN Neutron backend. Note that this backend does not support the VPNaaS plugin. Geneve will be used as the encapsulation method for tenant networks
 * A new answerfile was created in: /root/packstack-answers-20210804-023440.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client host 192.168.0.2. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://192.168.0.2/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.



Post a Comment

0 Comments